Create Method (Document, Element, IList(Curve), XYZ, ElementId, ElementId, ElementId)


Area Reinforcement Create(Document, Element, IList Curve , XYZ, Element Id, Element Id, Element Id) Method


Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static AreaReinforcement Create(
	Document document,
	Element hostElement,
	IList<Curve> curveArray,
	XYZ majorDirection,
	ElementId areaReinforcementTypeId,
	ElementId rebarBarTypeId,
	ElementId rebarHookTypeId
)

Parameters

document Document
hostElement Element
curveArray IList Curve
majorDirection XYZ
areaReinforcementTypeId ElementId
rebarBarTypeId ElementId
rebarHookTypeId ElementId

Return Value

AreaReinforcement
See Also