SetParameterDefaultValue Method


Rebar Shape Definition Set Parameter Default Value Method

Change the parameter's value as stored in the definition.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetParameterDefaultValue(
	ElementId paramId,
	double value
)

Parameters

paramId ElementId
Id of a parameter in the definition.
value Double
New value for the parameter.
Exceptions
Exception Condition
ArgumentException This RebarShapeDefinition does not have a value for the parameter paramId.
ArgumentNullException A non-optional argument was null
See Also