IsValidLayerPriority Method


Compound Structure Is Valid Layer Priority Method

Checks if the layer priority is valid to match the function.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public bool IsValidLayerPriority(
	int layerIdx,
	int priority
)

Parameters

layerIdx Int32
Index of a layer in the CompoundStructure. The layer index is zero based. It counts from the exterior of wall and from the top of roofs, floors and ceilings.
priority Int32
The priority of the layer to be checked.

Return Value

Boolean
Exceptions
Exception Condition
ArgumentOutOfRangeException The layer index is out of range.
Remarks
Membrane layers should not have priority, only 999 is allowed. For layers of other functions, priority value should be between 1 and 5.
See Also