FieldValues Class


Field Values Class

Contains values corresponding to domain points. Each domain point may have an array of values, each corresponding to a separate "measurement" for which this value was calculated.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Analysis FieldValues

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class FieldValues : IDisposable

The FieldValues type exposes the following members.

Constructors
Name Description
Public method FieldValues(FieldValues) Creates a copy of the given FieldValues instance.
Public method FieldValues(IList ValueAtPoint ) Initializes a new instance of the FieldValues class
Public method FieldValues(IList VectorAtPoint ) Initializes a new instance of the FieldValues class
Public method FieldValues(IList ValueAtPoint , XYZ) Initializes a new instance of the FieldValues class
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the FieldValues
Top
See Also