RebarCrankOverridableParameters Class


Rebar Crank Overridable Parameters Class

Class used to store the formula parameter ids defined in the RebarShape family which are associated with crank length, crank offset length, crank straight length and crank angled length parameters.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure RebarCrankOverridableParameters

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public class RebarCrankOverridableParameters : IDisposable

The RebarCrankOverridableParameters type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the RebarCrankOverridableParameters
Public method GetCrankEndAngledLengthFormulaParams Gets the formula parameter ids defined in the RebarShape family which are associated with end crank angled length parameters.
Public method GetCrankEndLengthFormulaParams Gets the formula parameter ids defined in the RebarShape family which are associated with end crank length parameters.
Public method GetCrankEndOffsetLengthFormulaParams Gets the formula parameter ids defined in the RebarShape family which are associated with end crank offset length parameters.
Public method GetCrankEndRatioFormulaParams Gets the formula parameter ids defined in the RebarShape family which are associated with end crank ratio parameters.
Public method GetCrankEndStraightLengthFormulaParams Gets the formula parameter ids defined in the RebarShape family which are associated with end crank straight length parameters.
Public method GetCrankStartAngledLengthFormulaParams Gets the formula parameter ids defined in the RebarShape family which are associated with start crank angled length parameters.
Public method GetCrankStartLengthFormulaParams Gets the formula parameter ids defined in the RebarShape family which are associated with start crank length parameters.
Public method GetCrankStartOffsetLengthFormulaParams Gets the formula parameter ids defined in the RebarShape family which are associated with start crank offset length parameters.
Public method GetCrankStartRatioFormulaParams Gets the formula parameter ids defined in the RebarShape family which are associated with start crank ratio parameters.
Public method GetCrankStartStraightLengthFormulaParams Gets the formula parameter ids defined in the RebarShape family which are associated with start crank straight length parameters.
Top
See Also