HandleBrowseResult Method


IExternal Resource UIServer Handle Browse Result Method

Implement this method to handle results from browsing external resources in the UI. It is recommended that the server only respond in the case of a critical error.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
void HandleBrowseResult(
	ExternalResourceUIBrowseResultType resultType,
	string browsingItemPath
)

Parameters

resultType ExternalResourceUIBrowseResultType
The result of the browsing operation.
browsingItemPath String
The absolute path of the current item being browsed.
Remarks
This method will be called automatically when the user browses for external resources, such as listing folders and resources of an external server or a subfolder, or choosing an external resource in the add resource dialog.
See Also