CanCrankParametersBeComputedUsingCrankAngledLength Method


Rebar Bar Type Can Crank Parameters Be Computed Using Crank Angled Length Method

Identifies if the all crank parameters can be computed for the specified crank angled length and Rebar Crank Type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public bool CanCrankParametersBeComputedUsingCrankAngledLength(
	ElementId rebarCrankTypeId,
	double crankAngledLength
)

Parameters

rebarCrankTypeId ElementId
The Rebar Crank Type id. Interactions with Rebar Crank Types can be done with the functions in [!:Autodesk::Revit::DB::Structure::RebarCrankTypeUtils] .
crankAngledLength Double
The value of the crank angled length to be tested.

Return Value

Boolean
Returns true if the crank paramters can be computed using the input crank angled length, false otherwise.
Exceptions
Exception Condition
ArgumentException The rebarCrankTypeId doesn't represent a valid Rebar Crank Type. It should be an ElementType of BuiltInCategory.OST_RebarCrankType category.
ArgumentNullException A non-optional argument was null
See Also