Rebar
|
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

public void SetFromCurves(
RebarStyle style,
RebarBarType barType,
RebarHookType startHook,
RebarHookType endHook,
XYZ norm,
IList<Curve> curves,
RebarTerminationOrientation startHookOrient,
RebarTerminationOrientation endHookOrient,
bool useExistingShapeIfPossible,
bool createNewShape
)
Parameters
- style RebarStyle
- barType RebarBarType
- startHook RebarHookType
- endHook RebarHookType
- norm XYZ
- curves IList Curve
- startHookOrient RebarTerminationOrientation
- endHookOrient RebarTerminationOrientation
- useExistingShapeIfPossible Boolean
- createNewShape Boolean