SlabShapeCrease Class


Slab Shape Crease Class

Represents a crease of a slab shape edited element.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB SlabShapeCrease

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class SlabShapeCrease : IDisposable

The SlabShapeCrease type exposes the following members.

Properties
Name Description
Public property CreaseType The type of the crease.
Public property Curve The geometry of the crease.
Public property EndPoints The vertices of the crease.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the SlabShapeCrease
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also