Importer
|
The main class provided by Revit to allow implementation of IFC import.

System
Object
Autodesk.Revit.DB.IFC ImporterIFC
Autodesk.Revit.DB.IFC ImporterIFC
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 26.0.4.0 (26.0.4.0)

The ImporterIFC type exposes the following members.

Name | Description | |
---|---|---|
![]() |
Document | Gets the document associated with the import. |
![]() |
FullFileName | The full file name of the IFC file to be import. |
![]() |
IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() |
Dispose | Releases all resources used by the ImporterIFC |
![]() |
Equals |
Determines whether the specified object is equal to the current object.
(Inherited from Object ) |
![]() |
GetHashCode |
Serves as the default hash function.
(Inherited from Object ) |
![]() |
GetOptions | Gets the collection of named options set by the importer client. |
![]() |
GetType |
Gets the
Type
of the current instance.
(Inherited from Object ) |
![]() |
ProcessIFCProject(IFCAnyHandle) | The entry point to the native IFC import function. Processes the main IfcProject and creates appropriate Revit elements. |
![]() |
ProcessIFCProject(IFCAnyHandle, IDictionary IFCAnyHandle, ElementId ) | |
![]() |
SetFile | Sets the handle to the IFC file being created during this import operation. |
![]() |
ToString |
Returns a string that represents the current object.
(Inherited from Object ) |

An instance of this class is provided to clients which implement IImporterIFC
in order to provide an implementation for IFC import. It contains information
on the options selected by the user for the import operation, as well as
members used to access specific types of data needed to implement the import
properly.