IntegerRange Class


Integer Range Class

A class to define a range of a sequence of consecutive integer numbers
Inheritance Hierarchy
System Object
Autodesk.Revit.DB IntegerRange

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class IntegerRange : IDisposable

The IntegerRange type exposes the following members.

Properties
Name Description
Public property High The upper limit of the range
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Low The lower limit of the range
Top
Methods
Name Description
Public method Dispose Releases all resources used by the IntegerRange
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also