AppendItemFromCurves(RebarStyle, RebarBarType, RebarHookType, RebarHookType, XYZ, IList<Curve>, RebarTerminationOrientation, RebarTerminationOrientation, Boolean, Boolean) Method


Rebar Container Append Item From Curves(Rebar Style, Rebar Bar Type, Rebar Hook Type, Rebar Hook Type, XYZ, IList Curve , Rebar Termination Orientation, Rebar Termination Orientation, Boolean, Boolean) Method


Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public RebarContainerItem AppendItemFromCurves(
	RebarStyle style,
	RebarBarType barType,
	RebarHookType startHook,
	RebarHookType endHook,
	XYZ normal,
	IList<Curve> curves,
	RebarTerminationOrientation startHookOrient,
	RebarTerminationOrientation endHookOrient,
	bool useExistingShapeIfPossible,
	bool createNewShape
)

Parameters

style RebarStyle
barType RebarBarType
startHook RebarHookType
endHook RebarHookType
normal XYZ
curves IList Curve
startHookOrient RebarTerminationOrientation
endHookOrient RebarTerminationOrientation
useExistingShapeIfPossible Boolean
createNewShape Boolean

Return Value

RebarContainerItem
See Also