DirectContext3DHandleOverrides Class


Direct Context 3DHandle Overrides Class

A set of DirectContext3DHandleSettings that are stored by a view.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.DirectContext3D DirectContext3DHandleOverrides

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DirectContext3DHandleOverrides : IDisposable

The DirectContext3DHandleOverrides type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Assign Assigns values of the source overrides to this object.
Public method Dispose Releases all resources used by the DirectContext3DHandleOverrides
Public method GetDirectContext3DHandleSettings Gets override settings associated with a DirectContext3D handle instance or type.
Public method IsEqual Check if the contents of two overrides are equal.
Public method SetDirectContext3DHandleSettings Assigns override settings associated with a DirectContext3D handle instance or type.
Top
See Also