IsDetailElement Method


Detail Element Order Utils Is Detail Element Method

Indicates if the element is a detail element that participates in detail draw ordering in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool IsDetailElement(
	Document document,
	View view,
	ElementId detailElementId
)

Parameters

document Document
The document.
view View
The view in which the detail appears.
detailElementId ElementId
The detail element.

Return Value

Boolean
True if the detail element is orderable in the view, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also