GetMergedParts Method


Part Utils Get Merged Parts Method

Retrieves the element ids of the source elements of a merged part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ICollection<ElementId> GetMergedParts(
	Part part
)

Parameters

part Part
A merged part.

Return Value

ICollection ElementId
The element ids of the parts that were merged to create the specified merged part.
Exceptions
Exception Condition
ArgumentException The specified Part is not a merged part.
ArgumentNullException A non-optional argument was null
See Also