CreateRectangle Method


Curve By Points Utils Create Rectangle Method


Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static void CreateRectangle(
	Document document,
	ReferencePoint startPoint,
	ReferencePoint endPoint,
	CurveProjectionType projectionType,
	bool boundaryReferenceLines,
	bool boundaryCurvesFollowSurface,
	out IList<ElementId> createdCurvesIds,
	out IList<ElementId> createdCornersIds
)

Parameters

document Document
startPoint ReferencePoint
endPoint ReferencePoint
projectionType CurveProjectionType
boundaryReferenceLines Boolean
boundaryCurvesFollowSurface Boolean
createdCurvesIds IList ElementId
createdCornersIds IList ElementId
See Also