ResetLayerPriority Method


Compound Structure Reset Layer Priority Method

Resets the priority of the specific layer to the default priority defined by its function.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public void ResetLayerPriority(
	int layerIdx
)

Parameters

layerIdx Int32
Index of a layer in the CompoundStructure. The layer index is zero based. It counts from the exterior of wall and from the top of roofs, floors and ceilings.
Exceptions
Exception Condition
ArgumentOutOfRangeException The layer index is out of range.
Remarks
The default priorities definition: Structure: 1, Substrate: 2, Thermal/Air Layer: 3, Membrane Layer: 999, Finish 1: 4, Finish 2: 5. In shell, a non-membrane layer which is closer to the core should not have a lower priority.
See Also