SetScheduleForDay Method


Building Operating Year Schedule Set Schedule For Day Method

Sets the BuildingOperatingDaySchedule for this day of the year.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public void SetScheduleForDay(
	DateTime day,
	BuildingOperatingDaySchedule daySchedule
)

Parameters

day DateTime
The day of the year. The value must be in 2023 (the template year) and have the time zone set to gmt/utc. Time values will be ignored.
daySchedule BuildingOperatingDaySchedule
The schedule used on that day.
Exceptions
Exception Condition
ArgumentException daySchedule must be in the same document.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException day must be in the year 2023.
Remarks
The day argument must be in 2023 to match the template year in the user interface calendar: it has 365 days and starts on a Sunday.
See Also