NumberingParameterId Property


Numbering Schema Numbering Parameter Id Property

Id of the parameter that stores values of the numbers on enumerated elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public ElementId NumberingParameterId { get; }

Property Value

ElementId
Remarks

Values of numbers can be obtained by querying this parameter for the respective numbered element.

Note: The parameter can be changed directly, but if a value that already exists in the sequence is provided a warning will be presented asking the user to select a proper course of action. Programmatically with better control the value can be changed(with restrictions) using the ChangeNumber(String, Int32, Int32) method.

See Also