NumberingSchema Class


Numbering Schema Class

A class to support assigning numbers to elements of a particular kind for the purpose of tagging and scheduling them. Complete configuration settings for formatting.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB Element
Autodesk.Revit.DB NumberingSchema

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public class NumberingSchema : Element

The NumberingSchema type exposes the following members.

Properties
Name Description
Public property AssemblyInstanceId The id of the assembly instance to which the element belongs.
(Inherited from Element )
Public property BoundingBox Retrieves a box that circumscribes all geometry of the element.
(Inherited from Element )
Public property Category Retrieves a Category object that represents the category or sub category in which the element resides.
(Inherited from Element )
Public property CreatedPhaseId Id of a Phase at which the Element was created.
(Inherited from Element )
Public property DemolishedPhaseId Id of a Phase at which the Element was demolished.
(Inherited from Element )
Public property DesignOption Returns the design option to which the element belongs.
(Inherited from Element )
Public property Document Returns the Document in which the Element resides.
(Inherited from Element )
Public property Geometry Retrieves the geometric representation of the element.
(Inherited from Element )
Public property GroupId The id of the group to which an element belongs.
(Inherited from Element )
Public property Id A unique identifier for an Element in an Autodesk Revit project.
(Inherited from Element )
Public property IsModifiable Identifies if the element is modifiable.
(Inherited from Element )
Public property IsTransient Indicates whether an element is transient or permanent.
(Inherited from Element )
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from Element )
Public property LevelId The id of the level associated with the element.
(Inherited from Element )
Public property Location This property is used to find the physical location of an element within a project.
(Inherited from Element )
Public property Static member MaximumStartingNumber A static property defining the maximum number a numbering sequence can use as its starting number (the lowest number in the sequence).
Public property Name A human readable name for the Element.
(Inherited from Element )
Public property NumberingParameterId Id of the parameter that stores values of the numbers on enumerated elements.
Public property OwnerViewId The id of the view that owns the element.
(Inherited from Element )
Public property Parameter BuiltInParameter Retrieves a parameter from the element given a parameter id.
(Inherited from Element )
Public property Parameter Definition Retrieves a parameter from the element based on its definition.
(Inherited from Element )
Public property Parameter Guid Retrieves a parameter from the element given a GUID for a shared parameter.
(Inherited from Element )
Public property Parameters Retrieves a set containing all of the parameters that are contained within the element.
(Inherited from Element )
Public property ParametersMap Retrieves a map containing all of the parameters that are contained within the element.
(Inherited from Element )
Public property Pinned Identifies if the element has been pinned to prevent changes.
(Inherited from Element )
Public property SchemaType Identifies the kind of elements/objects this numbering schema is used for.
Public property UniqueId A stable unique identifier for an element within the document.
(Inherited from Element )
Public property VersionGuid Get the element version Guid.
(Inherited from Element )
Public property ViewSpecific Identifies if the element is owned by a view.
(Inherited from Element )
Public property WorksetId Get Id of the Workset which owns the element.
(Inherited from Element )
Top
Methods
Name Description
Public method AppendSequence Appends all elements of one numbering sequence to the end of another sequence.
Public method ArePhasesModifiable Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element.
(Inherited from Element )
Public method AssignElementsToSequence
Public method CanBeHidden Indicates if the element can be hidden in the view.
(Inherited from Element )
Public method CanBeLocked Identifies if the element can be locked.
(Inherited from Element )
Public method CanDeleteSubelement Checks if given subelement can be removed from the element.
(Inherited from Element )
Public method CanHaveTypeAssigned Identifies if the element can have a type assigned.
(Inherited from Element )
Public method ChangeNumber Replaces an existing number with a new one (that does not exist yet).
Public method ChangeTypeId(ElementId) Changes the type of the element.
(Inherited from Element )
Public method DeleteEntity Deletes the existing entity created by %schema% in the element
(Inherited from Element )
Public method DeleteSubelement Removes a subelement from the element.
(Inherited from Element )
Public method DeleteSubelements
(Inherited from Element )
Public method Dispose
(Inherited from Element )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method EvaluateAllParameterValues Evaluates all the parameters' values of the element.
(Inherited from Element )
Public method EvaluateParameterValues
(Inherited from Element )
Public method GetDependentElements Get all elements that, from a logical point of view, are the children of this Element.
(Inherited from Element )
Public method GetEntity Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise.
(Inherited from Element )
Public method GetEntitySchemaGuids Returns the Schema guids of any Entities stored in this element.
(Inherited from Element )
Public method GetExternalFileReference Gets information pertaining to the external file referenced by the element.
(Inherited from Element )
Public method GetExternalResourceReference Gets the ExternalResourceReference associated with a specified external resource type.
(Inherited from Element )
Public method GetExternalResourceReferenceExpanded Gets the collection of ExternalResourceReference associated with a specified external resource type.
(Inherited from Element )
Public method GetExternalResourceReferences Gets the map of the external resource references referenced by the element.
(Inherited from Element )
Public method GetExternalResourceReferencesExpanded Gets the expanded map of the external resource references referenced by the element.
(Inherited from Element )
Public method GetGeneratingElementIds Returns the ids of the element(s) that generated the input geometry object.
(Inherited from Element )
Public method GetGeometryObjectFromReference Retrieve one geometric primitive contained in the element given a reference.
(Inherited from Element )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetMaterialArea Gets the area of the material with the given id.
(Inherited from Element )
Public method GetMaterialIds Gets the element ids of all materials present in the element.
(Inherited from Element )
Public method GetMaterialVolume Gets the volume of the material with the given id.
(Inherited from Element )
Public method Static member GetMinimumNumberOfDigits Returns the minimum number of digits to be used for formating the Number parameter of all enumerable elements of the given document.
Public method GetMonitoredLinkElementIds Provides the link instance IDs when the element is monitoring.
(Inherited from Element )
Public method GetMonitoredLocalElementIds Provides the local element IDs when the element is monitoring.
(Inherited from Element )
Public method Static member GetNumberingSchema Returns an instance of the specified Numbering Schema in the given document.
Public method GetNumberingSequences Returns all numbering sequences within this numbering schema.
Public method GetNumbers Returns all numbers currently used in the given numbering sequence
Public method GetOrderedParameters Gets the parameters associated to the element in order.
(Inherited from Element )
Public method GetParameter Retrieves a parameter from the element given identifier.
(Inherited from Element )
Public method GetParameterFormatOptions Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists.
(Inherited from Element )
Public method GetParameters Retrieves the parameters from the element via the given name.
(Inherited from Element )
Public method GetPhaseStatus Gets the status of a given element in the input phase
(Inherited from Element )
Public method Static member GetSchemasInDocument Returns a set of Ids of all Numbering Schema elements for a given document.
Public method GetSubelements Returns the collection of element subelements.
(Inherited from Element )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method GetTypeId Returns the identifier of this element's type.
(Inherited from Element )
Public method GetValidTypes Obtains a set of types that are valid for this element.
(Inherited from Element )
Public method HasPhases Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.
(Inherited from Element )
Public method IsCreatedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element )
Public method IsDemolishedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element )
Public method IsExternalFileReference Determines whether this Element represents an external file.
(Inherited from Element )
Public method IsHidden Identifies if the element has been permanently hidden in the view.
(Inherited from Element )
Public method IsMonitoringLinkElement Indicate whether an element is monitoring any elements in any linked models.
(Inherited from Element )
Public method IsMonitoringLocalElement Indicate whether an element is monitoring other local elements.
(Inherited from Element )
Public method IsPhaseCreatedValid Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.
(Inherited from Element )
Public method IsPhaseDemolishedValid Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element.
(Inherited from Element )
Public method Static member IsValidPartitionName Tests if the given string can be used as a name for a numbering partition.
Public method IsValidType(ElementId) Checks if given type is valid for this element.
(Inherited from Element )
Public method LookupParameter Attempts to find a parameter on the element which has the given name.
(Inherited from Element )
Public method MergeSequences
Public method MoveSequence Moves all elements of a numbering sequence from one partition to another.
Public method RefersToExternalResourceReference Determines whether this Element uses external resources associated with a specified external resource type.
(Inherited from Element )
Public method RefersToExternalResourceReferences Determines whether this Element uses external resources.
(Inherited from Element )
Public method RemoveGaps Removes gaps, if any, in a numbering sequence
Public method SetEntity Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten.
(Inherited from Element )
Public method Static member SetMinimumNumberOfDigits Sets a new value for the minimum number of digits to be used for formating the Number parameter of all numbered elements of the given document.
Public method ShiftNumbers Shifts all numbers in the sequence so the starting number has the given value.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks

Each NumberingSchema controls numbering of elements of one particular kind, typically of the same category such as Rebar or Fabric Reinforcement. Instances of NumberingSchema are also elements and there is always only one of each type in every Revit document. Available types of all built-in numbering schemas are enumerated in NumberingSchemaTypes class. At present, schema elements cannot be manually added, deleted, or copied. Attempts to do so will result in a failure warning and/or exceptions thrown.

Elements (e.g. Rebar) belonging to a particular schema (e.g. NumberingSchemaTypes.StructuralNumberingSchemas.Rebar) are organized and numbered in sequences. A sequence is a collection of elements that share the same numbering partition as defined by their respective values of the Partition parameter (NUMBER_PARTITION_PARAM). For a numbering sequence to exist it must contain at least one element. In other words, a sequence is established once there is at least one element of which the partition parameter has a value that differs from other elements (in the same numbering schema). If the last element is removed (deleted or moved to a different sequence) the then empty sequence ceases to exist.

Elements get assigned to sequences either upon their creation (based on the then current numbering partition value), or by explicitly modifying the Partition parameter of an element, or by using the AssignElementsToSequence method. It is highly recommended using that method over explicitly changing the Partition parameter, because the methods applies changes to sequences and element numbers immediately, while changed parameters get into effect only after the current transaction is closed.

In addition to directly or indirectly changing the Partition parameter of elements, numbering sequences can be reorganized by using methods of the NumberingSchema class. The MoveSequence method moves all elements of an existing sequence to a new sequence that does not exist yet in the schema, thus effectively renaming the Partition parameter on all the affected elements. The AppendSequence method removes all elements from one sequence and appends them to elements of another existing sequence while applying the matching policy. The method MergeSequences takes elements of all specified sequences and moves them all into a newly created sequence. All the merged elements will be renumbered and matched as needed based on the matching algorithm.

Elements in different sequences are numbered independently, meaning that there may be elements with the same number in two sequences even though the elements are different. Likewise, there may be perfectly identical elements in two or more sequences bearing different numbers. However, within each one numbering sequence any two identical elements will always have the same number, while different elements will never have the same number within a numbering sequence. Revit refers to this rule as the matching policy.

Enumerable elements are always numbered automatically upon their creation. Each new element will get an incrementally higher number. However, thanks to the matching policy, new elements that match existing elements within the same sequence will get the same number assigned. Elements will keep their assigned numbers as long as it is possible. This means, for example, that if some previously created elements (e.g. Rebar) get deleted, all remaining elements (within the same numbering sequence) will keep their numbers, which may result in gaps in the respective numbering sequence. Gaps can be removed by invoking RemoveGaps for sequences in which gaps are not desired.

Numbers are stored as values of a numbering parameter on each numbered element. The Id of the parameter is obtained by querying the NumberingParameterId property. The value of the number can be obtained by querying the parameter for the respective numbered element. The value is read-only and thus cannot be set; it is always computed based on relations of elements across numbering partitions and the matching policy within the numbering sequence of each element.

Even though numbers are always assigned automatically to all elements of a schema, the method ChangeNumber gives the programmer a way to explicitly overwrite a specific number as long as the new number is unique in the numbering sequence. The caller specifies a number to be changed and a new value that is to be applied, providing the value does not exist yet in the same numbering sequence. Although this operation may seem rather limited, it provides the programmer with freedom to change practically any number even if it may be achieved in multiple steps.

See Also