InternalDefinition Class


Internal Definition Class

This object represents a parameter definition in an Autodesk Revit model.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB Definition
Autodesk.Revit.DB InternalDefinition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class InternalDefinition : Definition, 
	IDisposable

The InternalDefinition type exposes the following members.

Properties
Name Description
Public property BuiltInParameter Tests whether this definition identifies a built-in parameter or not.
Public property Id The id of the parameter.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Name The user-visible name for the parameter.
(Overrides Definition Name )
Public property VariesAcrossGroups Whether or not the parameter values can vary across group members.
Public property Visible Indicates if the parameter is visible in the Autodesk Revit user interface.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the InternalDefinition
Public method GetGroupTypeId Gets the identifier of the built-in parameter group to which the parameter defined by this definition belongs.
(Overrides Definition GetGroupTypeId )
Public method GetParameterTypeId Tests whether this definition identifies a built-in parameter or not.
Public method GetTypeId Gets the identifier of the parameter.
Public method SetAllowVaryBetweenGroups Whether or not the parameter values can vary across group members.
Public method SetGroupTypeId Sets the built-in parameter group to which the parameter defined by this definition belongs.
Top
See Also