SetParticipatesInWrapping Method


Compound Structure Set Participates In Wrapping Method

Assigns if a layer is included in wrapping at inserts and ends.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public void SetParticipatesInWrapping(
	int layerIdx,
	bool participatesInWrapping
)

Parameters

layerIdx Int32
Index of a layer in the CompoundStructure. The layer index is zero based. It counts from the exterior of wall and from the top of roofs, floors and ceilings.
participatesInWrapping Boolean
True if the specified layer will participate in wrapping at inserts and ends, false otherwise.
Exceptions
Exception Condition
ArgumentException The wrapping of the layer is not valid.
ArgumentOutOfRangeException The layer index is out of range.
Remarks
This method applies only to interior and exterior shell layers.
See Also