PickedBox Class


Picked Box Class

A class that contains two XYZ points representing the pick box on the screen.
Inheritance Hierarchy
System Object
Autodesk.Revit.UI.Selection PickedBox

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PickedBox

The PickedBox type exposes the following members.

Properties
Name Description
Public property Max Maximum coordinates (upper-right-front corner of the pick box).
Public property Min Minimum coordinates (lower-left-rear corner of the pick box).
Top
Methods
Name Description
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also