Selection |
Provides access to user settings related to how selection will behave in Revit's UI.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

The SelectionUIOptions type exposes the following members.

Name | Description | |
---|---|---|
![]() | ActivateControlsAndDimensionsOnMultiSelect | Indicates whether controls and temporary dimensions are activated on selection of multiple elements. |
![]() | DragOnSelection | Indicates whether elements can be dragged immediately when they are selected. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | SelectFaces | Indicates whether elements can be selected by clicking on the interior of a face. |
![]() | SelectLinks | Indicates whether Revit and CAD link instances can be selected. |
![]() | SelectPinned | Indicates whether pinned elements can be selected. |
![]() | SelectUnderlay | Indicates whether elements that are displayed as underlay can be selected. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the SelectionUIOptions |
![]() ![]() | ElementSelectsAsPinned | Checks whether the specified element will be treated as pinned for the purposes of selection. |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() ![]() | GetSelectionUIOptions | Returns the current user's SelectionOptions. |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

The settings in this class define how selection will behave when the user is selecting one or more elements in a graphical view. These settings do not affect programmatic selection behavior. Some UI commands may override the user's settings while the command is active.
These settings are per user and will affect the selection behavior in all projects and families. The settings are not stored in the project.