CopyTemplate Method


IFCParameter Template Copy Template Method

Create copy of mapping template with new name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public IFCParameterTemplate CopyTemplate(
	Document document,
	string copyTemplateName
)

Parameters

document Document
The Revit document to save the copied template.
copyTemplateName String
The name for copied template name.

Return Value

IFCParameterTemplate
The copied mapping template element.
Exceptions
Exception Condition
ArgumentException The name already exists.
ArgumentNullException A non-optional argument was null
InvalidOperationException Failed to create IFCParameterTemplate element.
Remarks
The copied template is saved in the document passed as parameter. Passing the same document as the source template's document will create a new template in the same document. The active template of the document remains unchanged.
See Also