Create Method


IFCCategory Template Create Method

Create a IFC category mapping template with default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public static IFCCategoryTemplate Create(
	Document document,
	string name
)

Parameters

document Document
Document where created mapping template is saved.
name String
The name specified to this mapping template.

Return Value

IFCCategoryTemplate
The new mapping template instance.
Exceptions
Exception Condition
ArgumentException The name already exists.
ArgumentNullException A non-optional argument was null
See Also