NewFamilyDocument Method


Application New Family Document Method

New family document, including family, titleblock, and annotation symbol

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public virtual Document NewFamilyDocument(
	string templateFileName
)

Parameters

templateFileName String
The template file name.

Return Value

Document
Exceptions
Exception Condition
ArgumentException If 'templateFileName' is or an empty string.
InvalidOperationException If the new family document cannot be created.
Remarks
This command corresponds to File->New->Family.../TitleBlock.../Annotation Symbol....
See Also