GetCellText Method


Table Section Data Get Cell Text Method

Returns the text shown by this cell, if the cell's type is CellType.Text or CellType.ParameterText or CellType.CustomField.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public string GetCellText(
	int nRow,
	int nCol
)

Parameters

nRow Int32
The cell row.
nCol Int32
The cell column.

Return Value

String
The text in the cell, or an empty string if the type if not CellType.Text or CellType.ParameterText or CellType.CustomField.
Exceptions
Exception Condition
ArgumentException The given row number nRow is invalid. -or- The given column number nCol is invalid.
Remarks
For standard view schedules, to read the formatted text of the cell regardless of cell type, use [!:Autodesk::Revit::DB::ViewSchedule::GetCellText()] .
See Also