FabricationHostedInfo Class


Fabrication Hosted Info Class

The fabrication hosted element information.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB FabricationHostedInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FabricationHostedInfo : IDisposable

The FabricationHostedInfo type exposes the following members.

Properties
Name Description
Public property HostId Returns the identifier of the host.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method DisconnectFromHost Disconnects the part from the host.
Public method Dispose Releases all resources used by the FabricationHostedInfo
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetBearerCenterline Gets the centerline of the bearer. The method is applicable only for bearer hanger.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method PlaceOnHost(ElementId, Connector, Double) Places the part on the specified host.
Public method PlaceOnHost(ElementId, Connector, Double, Double) Places the part on the specified host.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
A fabrication part may have a host, the FabricationHostedInfo stores the host information for the fabrication part.
See Also