UpdateElements Method


IFCHybrid Import Update Elements(Document, String) Method

Note: This API is now obsolete.

Updates IFC Elements using AnyCAD.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
[ObsoleteAttribute("This is deprecated in Revit 2026.  Please use the updateElements function with the IFCHybridImportOptions.")]
public IList<ElementId> UpdateElements(
	Document doc,
	string file
)

Parameters

doc Document
Document to receive elements from the IFC file update.
file String
Full path of the file to import.

Return Value

IList ElementId
Returns an array of ElementIds representing created or updated elements.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also