IFCHybrid
|
Driver for Performing Hybrid Imports.

System
Object
Autodesk.Revit.DB.IFC IFCHybridImport
Autodesk.Revit.DB.IFC IFCHybridImport
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 26.0.4.0 (26.0.4.0)

The IFCHybridImport type exposes the following members.

Name | Description | |
---|---|---|
![]() |
IFCHybridImport | Constructs a new IFCHybridImport instance for importing IFC via Hybrid method. |

Name | Description | |
---|---|---|
![]() |
IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() |
CreateMap | |
![]() |
Dispose | Releases all resources used by the IFCHybridImport |
![]() |
Equals |
Determines whether the specified object is equal to the current object.
(Inherited from Object ) |
![]() |
GetHashCode |
Serves as the default hash function.
(Inherited from Object ) |
![]() |
GetIFCStepIdToElementIdMap | Retrieves the association between the original IFC STEP identifiers and the created or updated Elements. |
![]() |
GetType |
Gets the
Type
of the current instance.
(Inherited from Object ) |
![]() |
ImportElements(Document, String) |
Obsolete.
Imports IFC Elements using AnyCAD. |
![]() |
ImportElements(Document, String, IFCHybridImportOptions) | Imports IFC Elements using AnyCAD. |
![]() |
ToString |
Returns a string that represents the current object.
(Inherited from Object ) |
![]() |
UpdateElements(Document, String) |
Obsolete.
Updates IFC Elements using AnyCAD. |
![]() |
UpdateElements(Document, String, IFCHybridImportOptions) | Updates IFC Elements using AnyCAD. |