GetActiveDesignOptionId Method


Design Option Get Active Design Option Id Method

Gets the active design option id for the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public static ElementId GetActiveDesignOptionId(
	Document document
)

Parameters

document Document
The document.

Return Value

ElementId
The active design option id. It can be invalid id if there is no active design option in the document.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also