ExternalResourceMatchOptions Class


External Resource Match Options Class

Represents match options used to filter external resources when listing them from external resource server.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ExternalResourceMatchOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ExternalResourceMatchOptions : IDisposable

The ExternalResourceMatchOptions type exposes the following members.

Constructors
Name Description
Public method ExternalResourceMatchOptions Constructs new instance with specified resource type.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property ResourceType The desired resource type which external resources should match.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the ExternalResourceMatchOptions
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also