SetViewAnchorAndPosition Method


Viewport Set View Anchor And Position Method

Sets the ViewAnchor and position to Viewport.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public void SetViewAnchorAndPosition(
	ViewAnchor viewAnchor,
	XYZ position
)

Parameters

viewAnchor ViewAnchor
The viewAnchor to be assigned.
position XYZ
The position to be assigned.
Exceptions
Exception Condition
ArgumentException The given value of viewAnchor cannot be applied to this Viewport.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also