ITemporary |
Interface class for external server of TemporaryGraphicsHandlerService .
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

The ITemporaryGraphicsHandler type exposes the following members.

Name | Description | |
---|---|---|
![]() | GetDescription | Implement this method to return a description of the server. (Inherited from IExternalServer ) |
![]() | GetName | Implement this method to return the name of the server. (Inherited from IExternalServer ) |
![]() | GetServerId | Implement this method to return the id of the server. (Inherited from IExternalServer ) |
![]() | GetServiceId | Implement this method to return the id of the service. (Inherited from IExternalServer ) |
![]() | GetVendorId | Implement this method to return the id of the vendor of the server. (Inherited from IExternalServer ) |
![]() | OnClick | Handles mouse click event on a given temporary graphics object managed by TemporaryGraphicsManager . |