MEPAnalyticalNode Class


MEPAnalytical Node Class

Represents an analytical node of the MEP analytical model.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Analysis MEPAnalyticalNode

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class MEPAnalyticalNode : IDisposable

The MEPAnalyticalNode type exposes the following members.

Properties
Name Description
Public property Id The identity used in the MEPAnalyticalSegment
Public property IsFlowBlocked Is the flow blocked at this analytical node?
Public property IsFocalNode Is this node a focal point of multiple branches?
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Location The location of this node.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the MEPAnalyticalNode
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method IsSameNode Verify if this node is connected to the other node and thus represents the same analytical node in the network.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also