Electrical
|
Note: This API is now obsolete.
The wire type of the Electrical System.
Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

[ObsoleteAttribute("This property is deprecated in Revit 2026 and may be removed in a future version of Revit. Please use CableType instead. CableType will be set on ElectricalSystem properly during document upgrade.")]
public WireType WireType { get; set; }
Property Value
WireType
Exception | Condition |
---|---|
ArgumentNullException | When setting this property: A non-optional argument was null |

This property is used to retrieve the wire type of the Electrical System.