UIThemeManager Class


UITheme Manager Class

Manager object for the UITheme class.
Inheritance Hierarchy
System Object
Autodesk.Revit.UI UIThemeManager

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class UIThemeManager

The UIThemeManager type exposes the following members.

Properties
Name Description
Public property Static member CurrentCanvasTheme current canvas theme.
Public property Static member CurrentTheme The current overall theme which impacts the Revit frame and canvas.
Public property Static member FollowSystemColorTheme Indicate if the overall theme follows operating system color theme.
Top
Methods
Name Description
Public method Static member GetThemeName Gets the theme name for the given theme type.
Top
See Also