IFCPropertyMappingInfo(Boolean, String, ElementId, String) Constructor


IFCProperty Mapping Info(Boolean, String, Element Id, String) Constructor

Constructs a new IFCPropertyMappingInfo with input values. The flag that indicates whether the property is included in export. The property name. The Revit property id. The Revit property id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public IFCPropertyMappingInfo(
	bool exportFlag,
	string ifcPropertyName,
	ElementId revitPropertyId,
	string revitPropertyName
)

Parameters

exportFlag Boolean
ifcPropertyName String
revitPropertyId ElementId
revitPropertyName String
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also