IFCPropertyMappingInfo Class


IFCProperty Mapping Info Class

Represents the IFC property mapping information stored in the template.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB IFCPropertyMappingInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public class IFCPropertyMappingInfo : IDisposable

The IFCPropertyMappingInfo type exposes the following members.

Constructors
Name Description
Public method IFCPropertyMappingInfo Constructs a new IFCPropertyMappingInfo with default values.
Public method IFCPropertyMappingInfo(Boolean, String, ElementId, String) Constructs a new IFCPropertyMappingInfo with input values. The flag that indicates whether the property is included in export. The property name. The Revit property id. The Revit property id.
Top
Properties
Name Description
Public property ExportFlag Whether or not the property is included in export.
Public property IFCPropertyName The IFC property name.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property RevitPropertyId The Revit property id.
Public property RevitPropertyName The Revit property name.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the IFCPropertyMappingInfo
Public method Static member IsValidMappingInfo Defines whether the mapping info contains meaningful data.
Top
See Also