GetResourceVersionStatus Method


External Resource Reference Get Resource Version Status Method

Checks whether this ExternalResourceReference corresponds to the current version of the resource.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ResourceVersionStatus GetResourceVersionStatus()

Return Value

ResourceVersionStatus
An enum indicating whether this reference represents the most recent version of the resource.
Exceptions
Exception Condition
InvalidOperationException The server referenced by the ExternalResourceReference does not exist or does not implement IExternalResourceServer.
Remarks
This method should only be called if the ExternalResourceServer that provides the resource is present.
See Also