RemoveBuildingStorey Method


Exporter IFC Remove Building Storey Method

Note: This API is now obsolete.

Removes an IFCLevelInfo corresponding to a level from the exporter's internal cache.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
[ObsoleteAttribute("This is deprecated in Revit 2026.  Use ExporterCacheManager.LevelInfoCache.LevelsById instead.")]
public void RemoveBuildingStorey(
	ElementId id
)

Parameters

id ElementId
The level id.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also