ConnectDuctPlaceholdersAtElbow Method (Document, Connector, Connector)


Mechanical Utils Connect Duct Placeholders At Elbow(Document, Connector, Connector) Method

Connects a pair of placeholders that can intersect in an Elbow connection.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static bool ConnectDuctPlaceholdersAtElbow(
	Document document,
	Connector connector1,
	Connector connector2
)

Parameters

document Document
The document.
connector1 Connector
The end connector of the first placeholder.
connector2 Connector
The end connector of the second placeholder.

Return Value

Boolean
True if connection succeeds, false otherwise.
Exceptions
Exception Condition
ArgumentException The owner of connector is not duct placeholder. -or- The owners of connectors belong to different types of system.
ArgumentNullException A non-optional argument was null
Remarks
The placeholders may have a physical intersection but this is not required. If they are not intersecting the connectors must be coplanar and able to be moved to intersect each other. If connection fails, the placeholders cannot be physically connected.
See Also