GetPositionAtViewAnchor Method


Viewport Get Position At View Anchor Method

Gets the position coordinates at the ViewAnchor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public XYZ GetPositionAtViewAnchor(
	ViewAnchor viewAnchor
)

Parameters

viewAnchor ViewAnchor
The viewAnchor at which the position is requested.

Return Value

XYZ
The position at the ViewAnchor.
Exceptions
Exception Condition
ArgumentException The given value of viewAnchor cannot be applied to this Viewport.
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also