SetOverrideType Method


MEPAnalytical Segment Set Override Type Method

Sets the override type of pressure loss calculation.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public void SetOverrideType(
	MEPAnalyticalModelData analyticalModel,
	SegmentOverrideType overrideType
)

Parameters

analyticalModel MEPAnalyticalModelData
The analytical model data that this segment belongs to.
overrideType SegmentOverrideType
The new override type.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException The segment cannot be overridden for the pressure loss calculation.
See Also