TextNote Class


Text Note Class

A class representing text note annotations in Revit.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB Element
Autodesk.Revit.DB TextElement
Autodesk.Revit.DB TextNote

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class TextNote : TextElement

The TextNote type exposes the following members.

Properties
Name Description
Public property IsTextWrappingActive

A flag identifying whether text-wrapping is currently active in this text element or not.

If text wrapping is active the width of the text box remains constant and the text will wrap. The height of the text box will automatically adjust to accomodate the height of the text.

If text wrapping is not active the text does not wrap and the width of the text box adjusts with the width of the longest line of text. As the text width changes, the position of the text may change depending on the HorizontalAlignment

Public property LeaderCount Number of leader objects currently attached to the text note.
Public property LeaderLeftAttachment Attachment position of leaders on the left side of the text note.
Public property LeaderRightAttachment Attachment position of leaders on the right side of the text note.
Public property TextNoteType Access the type of the TextNote object.
Top
Methods
Name Description
Public method AddLeader Adds a leader to the text note.
Public method Static member Create(Document, ElementId, XYZ, String, ElementId) Creates a new unwrapped TextNote element with the given properties.
Public method Static member Create(Document, ElementId, XYZ, String, TextNoteOptions) Creates a new unwrapped text note element with the given properties.
Public method Static member Create(Document, ElementId, XYZ, Double, String, ElementId) Creates a new line-wrapping text note element of the given width and properties.
Public method Static member Create(Document, ElementId, XYZ, Double, String, TextNoteOptions) Creates a new line-wrapping text note element of the given width and properties.
Public method GetFormattedText Returns an object that contains text and associated formatting of this note.
Public method GetLeaders Returns a collection of leaders currently attached to the text note.
Public method RemoveLeaders Removes all leaders currently attached to the text note.
Public method SetFormattedText Sets the text and associated formatting of the text of in this text note with a given FormattedText object.
Top
See Also