GetSplitRegionOffset Method


View Crop Region Shape Manager Get Split Region Offset Method

Returns the offset for the specified split crop region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public XYZ GetSplitRegionOffset(
	int regionIndex
)

Parameters

regionIndex Int32
Index of the split crop region (numbering starts with 0).

Return Value

XYZ
A vector in model space representing the offset which is applied to the split crop region's boundary.
Exceptions
Exception Condition
ArgumentException The provided region index is invalid.
Remarks
The points in the split crop region's boundary are not in model space. Add the offset returned by this method to each point in the crop region's boundary to transform the points into model space coordinates.
See Also