GetAssociatedElementIds Method


Analytical To Physical Association Manager Get Associated Element Ids Method

Returns ids of the elements which are in association with the element with the given ElementId.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ISet<ElementId> GetAssociatedElementIds(
	ElementId elementId
)

Parameters

elementId ElementId
Element id for which we want to get the associated elements.

Return Value

ISet ElementId
Ids of the associated elements.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also