SetLayerPriority Method


Compound Structure Set Layer Priority Method

Sets the priority of the specific layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public void SetLayerPriority(
	int layerIdx,
	int priority
)

Parameters

layerIdx Int32
Index of a layer in the CompoundStructure. The layer index is zero based. It counts from the exterior of wall and from the top of roofs, floors and ceilings.
priority Int32
The priority of the layer.
Exceptions
Exception Condition
ArgumentException The priority of the layer is not valid.
ArgumentOutOfRangeException The layer index is out of range.
Remarks
The effective priority value should be between 1-5. Membrane layers should not have a priority, the value should be 999. You should set the layer priority if you want a customized priority value rather than the default one by function. In shell, a non-membrane layer which is closer to the core should not have a lower priority.
See Also