Curve |
An output node that represents a model curve.

System Object
Autodesk.Revit.DB RenderNode
Autodesk.Revit.DB ModelCurveNode
Autodesk.Revit.DB CurveNode
Autodesk.Revit.DB RenderNode
Autodesk.Revit.DB ModelCurveNode
Autodesk.Revit.DB CurveNode
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The CurveNode type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode ) |
![]() | LineProperties | Access to the line (pen) properties of the curve being drawn (Inherited from ModelCurveNode ) |
![]() | NodeName | A readable name of the output node. (Inherited from RenderNode ) |

Name | Description | |
---|---|---|
![]() | Dispose | (Inherited from RenderNode ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetCurve | Returns the geometric curve object corresponding to the node. |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

See also: [!:Autodesk::Revit::DB::IModelExportContext::OnCurve] .