Curve |
An output node that represents a model curve.

System Object
Autodesk.Revit.DB RenderNode
Autodesk.Revit.DB ModelCurveNode
Autodesk.Revit.DB CurveNode
Autodesk.Revit.DB RenderNode
Autodesk.Revit.DB ModelCurveNode
Autodesk.Revit.DB CurveNode
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The CurveNode type exposes the following members.

Name | Description | |
---|---|---|

Name | Description | |
---|---|---|
![]() | GetCurve | Returns the geometric curve object corresponding to the node. |

See also: [!:Autodesk::Revit::DB::IModelExportContext::OnCurve] .